Run a Program

0

I have an installer that works fine but normally the program will open after the install is finished. When deploying with PDQ, the program will not open until after a restart.
If I include a second step with a command simply pointing to the exe, PDQ will open the program on the remote PC but will sit at 'running'. If I abort, it closes the program on the remote machine. I imagine this is because it is waiting for the program to finish when really its just being open.

Is there anyway to get PDQ to open a program and then stop running the task? Is there another way to send a success code to PDQ telling it that the program opened successfully and that it is finished?

Cancel
login to comment
0

I was too quick to post...Found this and Shane's response helped me figure out the problem, which was I need to use 'Run as Logged on User' to execute the application.

 

https://support.adminarsenal.com/hc/en-us/community/posts/211686827-st6unst-exe-remote-execution

 

"You would just need to use a Command Step in your PDQ Package and have that step set to "Run as Logged On User". "

Cancel
login to comment

0

Hi, sorry to revive this, but do you know what the command looks like?  Is it simply like this:

 

start "c:\program files\app\app.exe"

 

I'm running into the same problem but haven't been able to get it to launch properly.  I followed this topic as well, but no luck:  

https://support.adminarsenal.com/hc/en-us/community/posts/211677287-Start-remote-program-but-don-t-wait

Cancel
login to comment

0

With the help of Brandon, I found that using the Start command to run the program will get PDQ to successfully complete the task.

Cancel
login to comment

Reply