Account Name Invalid

0

Hello all,

I have created a package to install feature updates for Windows 10, it was working quite well over the last couple months but recently I'm starting to see failures on some steps in the packages. I have done some research on this error and I have taken some steps to restart target systems before deployment, and also tried restarting Netlogon service. These didn't seem to have much effect, after the first deployment has completed things start failing. In the package to install Feature Update the final clean-up step often fails with the account name error. This final step deletes a folder from C:\ created at the start of this deployment, having this step fail isn't a big deal but it seems to cause problems with the subsequent package deployments.

The way I have the four packages set up, is like so:

  • Install Feature Update 1803 (Check version, Reboot, Copy source to c:, Stop A/V service and restart netlogon, Run in-place upgrade, Reboot (WARNS with Account Name Invalid), wait 25 minutes for updates to be applied after reboot, clean-up source files (FAILS))
    • Install Cumulative Updates (Package Library with Pre-step A/v disable and restart netlogon, Post-step reboot)
    • Install 2 specific KBs that are required, but not included in Cumulative.
    • Install Media Feature Pack (Check version, Stop A/V service and restart netlogon, Install MFP, Reboot)

I'm mainly seeing this error immediately after 1803 has successfully installed, it fails before step 1 has run on the Cumulative update. But I do also see this error on the final reboot of the first deployment as noted above. I understand doing a major upgrade like this is not intended to be done using PDQ, but the above process has worked well in the past. The background service account is a domain administrator so I don't believe there is any issues with the account specifically.

Just looking to see if anyone has ideas on how I can prevent this error, or better optimize the upgrades. It works, but lately I'm having to

I have no problem exporting my deployments if someone wants a closer look.

I appreciate the help and taking the time to read this post.

Cancel
login to comment
0

Do you use a domain account or a local account for your deployment ?

I often get "The account name is invalid or does not exist, or the password is invalid for the account name specified" error when patch our DC together with other servers.

domain admin account. Should I try local admin?

Local account should work better in this case.

Cancel
login to comment

Reply