Old AutoCAD install still asks for net 3.5 install

0

Hey there.

We're still using AutoCAD 2015 and every now and then it'll pop up with the built-into-windows time to install net framework 2/3.5.

Is there a way to nest net framework package that installs it for all types of Windows ? (7,10-1803,10-1809,10-1903) in a folder with the needed installer?

I realize I'd have to grab the package but im not sure how to do the identifying steps in the nested package to find out what OS it is nor how to install the correct package.

Cancel
login to comment
0

.Net 3.5 is a Windows feature. I use PowerShell to deploy it in my server environment (see the code example). You will need to copy the \sources\sxs folders out from all the Windows ISOs and put them to a network share.

$Server_Version =  (Get-CimInstance Win32_OperatingSystem).Version
switch ($Server_Version) {

'6.3.9600'  
  {
 
  Write-Host "Install .NET 3.5 on Server 2012R2"

  Install-WindowsFeature Net-Framework-Core -source \\$Your_Share\Dot_Net3_5\2012R2\sxs
  }


 '10.0.14393' 
  {
  
  Write-Host "Install .NET 3.5 on Server 2016"  
  
  Install-WindowsFeature Net-Framework-Core -source \\$Your_Share\Dot_Net3_5\2016\sxs

  }

 '10.0.17763' 

  {
  Write-Host "Install .NET 3.5 on Server 2019"  
  
  Install-WindowsFeature Net-Framework-Core -source \\$Your_Share\Dot_Net3_5\2019\sxs
  }

}

Alternatively you can also use the build in Conditions (Windows 7, Windows 10) to push out the installer directly. enter image description here

Cancel
login to comment

Reply