"The directory name is invalid." when deploying .bat

0

Hello,

I am a trying to use the free version of PDQ to deploy some simple .bat files, and I'm having trouble with one in particular. It is a .bat used to install a specific version of Java needed for an older application - unfortunately I don't have an .msi available and re-wrapping isn't an option. The BAT works flawlessly when I run it locally on my computer, but if I deploy through PDQ it kicks back a "The directory name is invalid" error.

The contents of the BAT are below:

    copy \\dafiler\sw\Win10\sw\Java\jre1.6.0_45\Temp\Java645.exe C:\Temp
    C:\Temp\java645.exe /s

Error Log:

C:\Windows\AdminArsenal\PDQDeployRunner\service-1\exec>copy \\dafiler\sw\Win10\sw\Java\jre1.6.0_45\Temp\Java645.exe C:\Temp 
        1 file(s) copied.

C:\Windows\AdminArsenal\PDQDeployRunner\service-1\exec>C:\Temp\java645.exe /s 
The directory name is invalid.

I have tried tweaking and changing things about 30 times now, and can't figure out why it won't run the .exe from C:\Temp. Some of the changes I've tried are to add a CD to C:\Temp, or to copy the installer exe to different paths, but nothing seems to work. I can confirm it copies the file to the right location, but it just refuses to run.

I've also tried the fix listed here to no avail: https://support.microsoft.com/en-us/help/832434/the-directory-name-is-invalid-error-message-when-you-start-cmd-exe-or

Cancel
login to comment
0

I can not explain why your .bat doesen't work, but i'm asking me why you don't use the java.exe directly with PDQ Deploy?

Create a "custom" Folder in your PDQ Repository (you can find the path under PDQ Deploy -> Options -> preferences -> repository) and put in the java645.exe.

Create a custom install package, point to the java645.exe an set the parameter /s

This should solve the problem

Greetings

I eventually figured out what the issue with the BAT was - there was a typo in the computer name and it was deploying to the wrong machine. The reason we were trying a batch was because the MSI wouldn't deploy the normal way, no matter what switches we put on it it would just spin endlessly without finishing or erroring out.

Cancel
login to comment

Reply